
PilotLog Offline for Symbian UIQ

Version 2.0.2

User Guide

PilotLog Offline is a companion flight editor for the online PilotLog system. Provisional flight and simulator 
detail information is downloaded to your phone, where the details can be updated then re-synchronised 
with your online log. It is also possible to add new flights and simulator details directly on the phone if they 
were not previously entered online.

Note : Your entire log is not synchronised with the phone; most data is kept on the online server, and only 
flights and sim details marked as provisional (or newly entered offline) are stored on the phone. This 
minimises memory and processing requirements on your phone, while allowing you to keep your log up to 
date without an internet connection.
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1.0 Getting Started

Download the Program
1. Login to your PilotLog account, using the User Name and Password as shown on your PilotLog 

membership card.
2. Download the PilotLog Offline for Symbian UIQ program from the PilotLog website. This can be 

found at: http://www.pilotlog.co.uk/downloads.php. 
3. Save this file 'PilotLog.sis' to your computer, somewhere that will ensure that it can be found easily 

later (for example, 'Desktop' or 'My Documents').

Install the Program
4. Connect your phone to your computer.
5. Copy the 'PilotLog.sis' file to your phone.
6. On your phone, tap Launcher -> Install, then select ‘PilotLog Offline’ and follow the prompts.

There  will  be  warnings that  the  software  is  not  signed  by  a  known software author  –  these  can be 
accepted, and the installation continued.

Note : The above steps can be bypassed by downloading the installation file directly to your phone, using 
the Symbian web browser to open:
http://www.pilotlog.co.uk/log/download/symbian/downloadPLOSymbian.php
You will be prompted to login using the User Name and Password as shown on your PilotLog membership 
card. Once the file has downloaded, it should install automatically. If it does not, follow step 6 above.
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2.0 Before Running PilotLog Offline for the First Time

IMPORTANT!!!  DO NOT add any flight data until after you have completed the following:

Note :  This section can be skipped  if you already have a 'log.csv' file on your phone, from a previous 
version of PilotLog Offline.

 1. Download a 'log.csv'  file from PilotLog online.  This can be done by logging into your PilotLog 
account, and going to 'Tools -> New PilotLog Offline log.csv File'. You will be warned about the 
danger of overwriting existing 'log.csv' files, then allowed to download the data. 

 2. Connect your phone to your computer.
 3. Copy the 'log.csv' file to your phone, saving it in a location that you will be able to find again. You 

can alternatively copy your log.csv file onto a memory card and use this to transfer data between 
your computer and phone if you have a suitable card reader.

If you do not download a log.csv file, but instead add flights on the device directly, a log.csv file will be 
automatically  created  in  the  same  folder  as  the  program  was  installed.  By  default,  this  is 
'c:\system\apps\PilotLog'. It is important to download a log file, as this will contain historical hours data for 
calculating totals, even if there are no provisional flights.

3.0 Running PilotLog Offline for the First Time

 1. To run PilotLog Offline, tap the ‘PilotLog Offline’ icon which will appear on the Launcher screen.
 1. The warning 'Log.csv file not found' will be displayed if PilotLog Offline cannot find the 'log.csv' file 

downloaded in Section 2.0 above.
 2. To load the 'log.csv' file, go to 'Tools -> Open Log File'.
 3. A screen as seen here will appear. Select the disk and folder in which you saved your 'log.csv' file 

(generally, if you saved it to your phone, it will be in 'C' drive, and probably the 'Documents' folder. 
If on a memory card, the disk will probably be 'D'.

 4. Set the hours display format ('Tools -> Hours Display') to suit your personal preference.  As in the 
online log, this affects all hours totals, and the entry of simulator detail durations. Flight times are 
always entered as hh:mm. 
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4.0 Using PilotLog Offline

Depending on your circumstances, there are several ways to use PilotLog Offline:

If your company produces planned rosters in a form that can be downloaded to PilotLog, import your 
planned roster online*. Synchronise with PilotLog Offline and all the planned flights will be copied to your 
phone. Enter actual flight times and other information on the flight deck as you complete each flight, then 
synchronise with your online log at a convenient time.

If you have a planned roster but no download facility, you can enter your planned roster manually online or 
offline as provisional flights. Then simply synchronise as above. Only flights marked as provisional will be 
downloaded, so you must check the 'provisional' option when entering planned flights online. These flights 
will be highlighted in grey in your online log, and marked with a 'P' in PilotLog Offline.

If you have no planned roster, or operate unplanned flights (e.g. from standby), you can add the flight(s) 
using PilotLog Offline on the flight deck. The new flights will be inserted into your online log book when you 
synchronise.

The main screen shows summary information:

The  number  of  flights  &  sims  stored  on  your  phone,  and  the 
number of these which are provisional, as opposed to confirmed 
data.  If  there  are  provisional  flights,  you  will  be  offered  the 
opportunity to 'tap to edit flights'. If there are no provisional flights, 
the option will instead be 'tap to add a flight'.

Your total flying hours in the past 28 days up to today. The figure 
in brackets includes provisional (planned) flights, if there are any in 
the period.

Projected flying hours for the 28 days up to tomorrow, again with a 
provisional  figure  in  brackets  if  there  are  any  planned  flights 
affecting this period.

Total hours in your log book.

Flights can be added, edited and deleted on the phone using the Flight menu option in the top-left hand 
corner of the screen. Note that deleting flights from the phone will not delete them from your online log. 
The delete option is provided only for deleting flights added in error on the phone.

The Sim menu provides similar facilities to add, edit or delete simulator details. Again, sim details deleted 
offline will not be removed from your online log.

The tools menu allows you to open a 'log.csv' file on your phone. This setting is stored, so your log file will 
be opened automatically unless you change the location in which it is stored. If you move your 'log.csv' file, 
you must tell PilotLog Offline where to find it using the 'Open Log File' option. You can also select your 
preferred hours display format. This affects totals displayed on the main screen, and flight and sim duration 
displays. Flight departure and arrival times will always be displayed as hh:mm.

The Help menu contains a link to the About screen, showing software version information which you should 
quote in any support queries.

To close the program, tap 'Flight -> Exit'.

* Note : Not all roster formats have been submitted to PilotLog for configuration. If you would like to use 
this feature but find that it is not available, please e-mail us at development@pilotlog.co.uk, attaching 
sample rosters.
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4.1 Adding Flights

Tap 'Flight -> Add' (or simply tap the screen if there are no provisional flights, and the message 'Tap 
Screen to Add a Flight' is displayed).

Dates must be entered in dd/mm/yyyy format. Times can be 
entered as hh:mm, h:mm, hhmm or hmm. Note that the colon 
(:) can be omitted for ease of typing on the phone.

Airports should be entered as ICAO codes, although IATA codes 
will also be recognised, as will full or part names. Note that 
airport names (and aircraft registrations) will not be checked 
until you synchronise your flights online. Errors may be difficult 
to spot, so it is better to stick to ICAO or IATA codes.

'Crew' is the crew capacity under which you operated the flight.

The check-box options correspond to the options in the PilotLog 
program:

A – Autoland
L – Landing Pilot (checked depending on crew capacity)
I – Instrument Flight (checked by default)
X – Exclude Hours (from 28-day totals etc)
P – Provisional Data

Buttons are provided next to the Reg, PiC, P2, From and To boxes. Tapping these will copy the 
corresponding value from the last flight added.

The button above the 'Comment' box works in a similar way to other buttons. It will copy the 
comment from the last flight added, but rather than overwriting the current comment, it will add the 
text to any already there so that information is not accidentally lost.

Tap 'OK' in the bottom right-hand corner of either screen to save the flight details. Tapping 'Discard 
Changes' will lose the current flight data and return to the previous screen.
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4.2 Editing Flights

Tap  'Flight  ->  Edit'  (or  simply  tap  the  screen  if  there  are 
provisional flights, and the message 'Tap Screen to Edit Flights' is 
displayed). 

You will be presented with a list of stored flights. The information 
displayed is date (day/month only to save space), departure airport 
and time, arrival airport and time, duration. A 'P' before a flight 
signifies that the flight is provisional.

Select the flight you wish to edit by scrolling through the list then 
clicking the scroll wheel, or tapping on it with the stylus. You can 
also scroll to an entry, then tap 'Edit'.

The editing display is exactly the same as for adding a new flight. 
When editing a flight, the 'copy' buttons work slightly differently to 
adding a new flight. Rather that copy the values from the last flight 
entered, they copy from the previous flight in chronological order. 
This means that, for example, if you operate a series of flights on 
the same aircraft having already entered them as provisional data, 
you can enter the registration once for the first flight, then use the 'copy' button to copy that information 
into subsequent flights without any further typing.

Note : When you edit a provisional flight, the 'P' box is automatically unchecked as it is assumed that once 
a flight has been edited it is confirmed, and no longer provisional data. You can of course re-check the 'P' 
box manually. This will happen if you view a flight and tap 'OK' – if you just wish to view a provisional flight 
without  making  any  changes,  you  should  tap  'Discard  Changes'  to  avoid  saving  the  flight  as  non-
provisional.

4.3 Deleting Flights

Tap 'Flight -> Delete'.

You will be presented with a list of stored flights similar to that used to select a flight to edit. Select a flight 
then tap 'Delete'. You will first be asked to confirm that you wish to delete the flight, and when you click 
'OK' it will be permanently deleted. Unlike when editing a flight, you must tap 'Delete'; you cannot click the 
scroll wheel or tap on a flight to delete it.

Note  : Deleting  a  flight  in  PilotLog  Offline  will  not  remove  it  from  your  online  log  next  time  you 
synchronise. The delete option is provided only for deleting flights added offline. To remove provisional 
flights from your online log, you must delete then online. This is a safety feature designed to prevent 
accidental deletion of data from your online log during synchronisation.

Revision 5 – 24/7/2006 Page 6 © 2005-06 MJICCS



4.4 Adding Sims

Tap 'Sim -> Add'.

Dates must be entered in dd/mm/yyyy format.

Duration must be entered in the format selected from the 'Tools -> 
Hours Display Format' menu, i.e. h:mm, h.m or h.mm. Regardless 
of the format selected, it is acceptable to enter a single digit (e.g. 
'4' instead of '4:00') which will be assumed to be a whole number 
of hours.

Title is a short description of the detail. 'Detail' refers to the type of 
sim detail.

The 'Sim' box is for the simulator name. This could be the aircraft 
type, and/or the full  approved simulator registration code. 'Type' 
refers to the type of simulator.

'Ins' is an abbreviation of 'Instructor'. Enter the crew names in the 
three corresponding boxes.

'Crew' is the crew capacity in which you acted during the detail.

The 'P' box on the right hand side marks the detail as provisional.

The 'copy' buttons work as for adding a flight, in that the ones next to the crew names boxes will copy the 
crew names from the last sim added, while the one above the comment box will add the previous comment 
to any text already in the box. The 'Title' and 'Sim' buttons will copy both the text and drop-down option 
from the last sim detail (e.g. in the figure above, 'Sim Check' and 'LPC/OPC' would both be copied by 
tapping 'Title').

Tap 'OK' in the bottom right-hand corner of either screen to save the sim details. Tapping 'Discard Changes' 
will lose the current sim data and return to the previous screen.

4.5 Editing Sims

Tap 'Sim -> Edit'. The process is the same as described in '4.2 Editing Flights', including the notes on 
provisional sims being automatically marked as non-provisional and the copy buttons copying from the 
previous detail rather than the last one added.

4.6 Deleting Sims

Tap 'Sim -> Delete'. The process is the same as described in '4.3 Deleting Flights'. You will be asked to 
confirm before any sim detail is deleted. Details deleted offline will not be removed from your online log.
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5.0 Synchronising With Your Online Log

To synchronise, you must upload the 'log.csv'  file from your phone to the PilotLog.co.uk website. Any 
flights and/or sim details which you have added or modified offline will be copied into your online log. 
Aircraft registrations and airports will be matched against the main online database in the same way as if 
you had entered the details directly online. Any errors or warnings will be displayed on screen. If you have 
modified both the online and offline versions of a flight or sim detail, you will be asked which one you wish 
to keep.

First, you must copy your 'log.csv' file from your phone to your computer. This can be achieved via a cable 
connection, bluetooth file transfer or using a memory card and a card reader on your computer.

To upload your 'log.csv' file, log in to your online log and click 'Tools -> Synchronise with PilotLog Offline'. 
Browse to the folder on your computer where you have stored your 'log.csv' file.

After  synchronisation,  you  must  download  a  new 'log.csv'  file.  There  is  a  button  at  the  end  of  the 
synchronisation window to do this, or you can use the 'Tools -> New PilotLog Offline log.csv File' menu 
option. Save this downloaded file to your computer, then copy it back to your phone. You should save it in 
the same location as the old 'log.csv' file, overwriting the old version with the new one.

Next time you run PilotLog Offline, it will load the new file and display any downloaded provisional flights 
and sim details. If PilotLog Offline was running during synchronisation, the file will only be loaded if you 
close then re-start the program, or use 'Tools -> Open Log File' to load the new log file manually.
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6.0 Troubleshooting

No flights or sim details have been downloaded to my phone

Only provisional flights and sims are downloaded. If you have no provisional data online, then nothing will 
be downloaded. You should still see hours totals information on the PilotLog Offline main screen, and you 
can add flights and sim details offline. These will be added to your online log when you synchronise.

All the flights I added offline disappeared when I synchronised my log

See above. If the flights were added as non-provisional data, they are copied to your online log during 
synchronisation. As only provisional flights are downloaded in the new 'log.csv' file, you will not see the 
flights you added in PilotLog Offline after synchronisation.
This is to save space and processing power on your phone. If you require a copy of your historic log to 
carry with you, consider downloading a backup log file (online, 'Tools -> Download Backup Log File'). See 
the online help file for further information.

When I run PilotLog Offline, I get an error 'log.csv file not found'

First, be sure that you have downloaded a 'log.csv' file and copied it to your phone. If it is missing, you can 
download a new one from your online log ('Tools -> New PilotLog Offline log.csv File').
If the file is present, then you just need to tell PilotLog Offline where to find it. See  section 3.0 of this 
guide.

I've added flights offline but I can't find my 'log.csv' file

If you add flights without first downloading and locating a 'log.csv' file as described in these instructions, 
PilotLog Offline will automatically create a 'log.csv' file for you. It will contain any information added offline, 
but of course not your hours totals from your online log. The file will be stored in the same folder as the 
PilotLog Offline program. By default, this is 'c:\system\apps\PilotLog'.
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