PilotLog Offline for Pocket PC
Version 2.0.5

User Guide

PilotLog Offline is a companion flight editor for the online PilotLog system. Provisional flight and simulator
detail information is downloaded to your PDA, where the details can be updated then re-synchronised with
your online log. It is also possible to add new flights and simulator details directly on the PDA if they were
not previously entered online.

Note : Your entire log is not synchronised with the PDA; most data is kept on the online server, and only
flights and sim details marked as provisional (or newly entered offline) are stored on the PDA. This
minimises memory and processing requirements on your PDA, while allowing you to keep your log up to
date without an internet connection.
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1.0 Getting Started

Download the Program
1. Download the PilotLog Offline for Pocket PC program from the PilotLog website. This can be found
at: http://www.pilotlog.co.uk/downloads.php. You will need to log in to access the PilotLog Offline
program.
2. Save this file 'PilotLog Offline.cab’ to your computer, somewhere that will ensure that it can be
found easily later (for example, 'Desktop' or 'My Documents').

Install the Program

3. Connect your PDA to your PC, using the using the docking cradle / cable / bluetooth connection.

Allow Active Sync to run.

4. Whilst the PC and PDA are connected, Go to 'My Computer' and double-click the 'Mobile Device'
icon. This will open up a window of the 'My Documents' file of your PDA.
On your PC, find the 'PilotLog Offline.cab' file, as saved in step 3 above.
Drag the 'PilotLog Offline.cab' from your PC to 'My Documents' on your PDA.
On your PDA, launch File Explorer ('Start -> Programs -> File Explorer'), and find 'My Documents'.
Tap the 'PilotLog Offline.cab' file to install PilotLog Offline.

Nowu

Users of recent versions of Windows Mobile may see a warning after installation: "The program you have
installed may not display properly because it was designed for a previous version of Windows Mobile
Software'. This is due to the fact that the program is designed to run on any version of PocketPC from 2002
onwards, and is not a problem.

Note : The above procedure can be skipped by downloading the PilotLog Offline program directly to your
PDA. This can be done by connecting your PDA to the internet (either directly, or using ActiveSync) and
using your Pocket PC web browser to open:
http://www.pilotlog.co.uk/log/download/ppc/downloadPLOPPC.php. You will be prompted to login using the
User Name and Password as shown on your PilotLog membership card.

Login and you will be able to download the 'PilotLog Offline.cab’ file to the 'My Documents' folder on your
PDA. Ensure that the 'Open file after download' box is checked and tap 'Yes'. This will automatically install
the PilotLog Offline program to your PDA. If the installation does not begin automatically, use File Explorer
to locate the 'PilotLog Offline.cab' file that you downloaded, and tap it to install.
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2.0 Before Running PilotLog Offline for the First Time

IMPORTANT!!! DO NOT add any flight data until after you have completed the following:

Note : This section can be skipped if you already have a 'log.csv' file on your PDA, from a previous version
of PilotLog Offline.

1.

2.

Connect your PDA to your PC, using the using the docking cradle / cable / bluetooth connection.
Allow ActiveSync to run. Do not disconnect...

Download a 'log.csv' file from PilotLog online. This can be done by logging into your PilotLog
account, and going to 'Tools -> New PilotLog Offline 'log.csv' File'. You will be warned about the
danger of overwriting existing 'log.csv' files, then allowed to download the data.

Save the 'log.csv' file to your PDA, by navigating to 'My Documents' on your PC, then 'PDA My
Documents'. The 'log.csv' file can be saved anywhere within the PDA documents folder; if you
choose, you can create a PilotLog folder to save it in, allowing you to keep your documents neatly
organised.

3.0 Running PilotLog Offline for the First Time

[uy

5.

To run PilotLog Offline, go to 'Start menu -> Programs -> PilotLog Offline'

The warning 'Log.csv file not found' will be displayed if PilotLog Offline cannot find the 'log.csv' file
downloaded in Section 2.0 above.

To load the 'log.csv' file, go to 'Tools -> Open Log File'.

A screen as seen here will appear. It will list all 'log.csv' files found on your PDA. Tap on the correct
file to open it.

Folder: |ﬂ«|| Folders v|| Cancel |
Type: |F'i||:|tL|:u;| Files v|

MNarne & Folder Date

4| in [ E|‘

Set the hours display format (‘Tools -> Hours Display") to suit your personal preference. As in the
online log, this affects all hours totals, and the entry of simulator detail durations. Flight times are
always entered as hh:mm.
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4.0 Using PilotLog Offline
Depending on your circumstances, there are several ways to use PilotLog Offline:

If your company produces planned rosters in a form that can be downloaded to PilotLog, import your
planned roster online*. Synchronise with PilotLog Offline and all the planned flights will be copied to your
PDA. Enter actual flight times and other information on the flight deck as you complete each flight, then
synchronise with your online log at a convenient time.

If you have a planned roster but no download facility, you can enter your planned roster manually online or
offline as provisional flights. Then simply synchronise as above. Only flights marked as provisional will be
downloaded, so you must check the 'provisional' option when entering planned flights online. These flights
will be highlighted in grey in your online log, and marked with a 'P' in PilotLog Offline.

If you have no planned roster, or operate unplanned flights (e.g. from standby), you can add the flight(s)
using PilotLog Offline on the flight deck. The new flights will be inserted into your online log book when you
synchronise.

f£iF |pilotLog Offine & 4x 22:08 €
The main screen shows summary information:

PilotLog Offline

The number of flights & sims stored on your PDA, and the wh.pilotiog. co.uk

number of these which are provisional, as opposed to confirmed

data. If there are provisional flights, you will be offered the 42 Flights Stored on Device
opportunity to 'tap to edit flights'. If there are no provisional LAl Marked as Provisional)
flights, the option will instead be 'tap to add a flight'. Mo Sims ta Display

Your total flying hours in the past 28 days up to today. The Tap Screen to Edit Flights

figure in brackets includes provisional (planned) flights, if there 26 Day Tatal | 48:30
are any in the period. Tomorros ;4409
Projected flying hours for the 28 days up to tomorrow, again Grand Total Hours @ 3880:21

with a provisional figure in brackets if there are any planned
flights affecting this period.

Total hours in your log book. Flight Sim Tools Help E|A

Flights can be added, edited and deleted on the PDA using the Flight menu option in the bottom-left hand
corner of the screen. Note that deleting flights from the PDA will not delete them from your online log. The
delete option is provided only for deleting flights added in error on the PDA.

The Sim menu provides similar facilities to add, edit or delete simulator details. Again, sim details deleted
offline will not be removed from your online log.

The tools menu allows you to open a 'log.csv' file on your PDA. This setting is stored, so your log file will be
opened automatically unless you change the location in which it is stored. If you move your 'log.csv' file,
you must tell PilotLog Offline where to find it using the 'Open Log File' option. You can also select your
preferred hours display format. This affects totals displayed on the main screen, and flight and sim duration
displays. Flight departure and arrival times will always be displayed as hh:mm.

The Help menu contains a link to the About screen, showing software version information which you should
quote in any support queries.

To close the program, either tap the 'X' icon in the top right hand corner, or tap 'Flight -> Exit'.

* Note : Not all roster formats have been submitted to PilotLog for configuration. If you would like to use
this feature but find that it is not available, please e-mail us at development@pilotlog.co.uk, attaching
sample rosters.
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4.1 Adding Flights

Tap 'Flight -> Add' (or simply tap the screen if there are no
provisional flights, and the message 'Tap Screen to Add a Flight'
is displayed).

The first screen contains most flight information. Dates must be
entered in dd/mm/yyyy format. Times can be entered as hh:mm,
h:mm, hhmm or hmm. Note that the colon (:) can be omitted for
ease of typing on the PDA.

Airports should be entered as ICAO codes, although IATA codes
will also be recognised, as will full or part names. Note that
airport names (and aircraft registrations) will not be checked
until you synchronise your flights online. Errors may be difficult
to spot, so it is better to stick to ICAO or IATA codes.

'Crew' is the crew capacity under which you operated the flight.

The check-box options correspond to the options in the PilotLog
program:

A — Autoland

L — Landing Pilot (checked depending on crew capacity)
I — Instrument Flight (checked by default)

X — Exclude Hours (from 28-day totals etc)

P — Provisional Data

The 'Reg', 'PiC', 'P2', 'From' and 'To' captions are tappable
corresponding value from the last flight added.

Tap 'Comment..." to enter further details:

The 'Comment' caption works in a similar way to the buttons on
the previous screen. It will copy the comment from the last flight
added, but rather than overwriting the current comment, it will
add the text to any already there so that information is not
accidentally lost.

Tap 'Back...' to return to the previous screen.
Tap 'OK' in the top right-hand corner of either screen to save the

flight details. Tapping 'Discard Changes' will lose the current
flight data and return to the main screen.
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4.2 Editing Flights

Tap 'Flight -> Edit' (or simply tap the screen if there are
provisional flights, and the message 'Tap Screen to Edit Flights' is
displayed). Tap a Flight to Edit

11/07 EGKE 13:15 LEBL 15:20 (2.1}
11/07 LEBL 16:00 EGKE 18:15 (2.3)
11/07 EGKE 19:15 EGI] 20:15(1.0)
12/07 EG1] 12:25 EGKK 13:20 (0.9)
12/07 EGKE 14:50 EG1] 15:50(1.0)
12/07 EG1] 16:30 EGKK 17:25 (0.9)
12/07 EGKE 15:40 EDDM 20:25 (1.8)
13/07 ECDM 15:30 EGKE 17:25(1.9)
13/07 EGKE 18:25 LEMD 20:55 (2.5)
13/07 LEMD 21:35 EGKE 23:40 (2.1}
14/07 EGKE 21:55 LBSF 01:15(3.3)
15/07 LBSF 02:00 EGKK 05:35 (3.6)
18/07 EGKE 12:25 LIRF 14:30 (2.1}
18/07 LIRF 15:15 EGKK 17:25 (2.2)
18/07 EGKE 15:35 EHAM 19:45(1.2)
19/07 EHAM 10:15 EGKE 11:25(1.2)

£iF|pilotLog Offine  &F Wx 2212 @

[ »

The editing display is exactly the same as for adding a new flight.
You will be presented with a list of stored flights. The information
displayed is date (day/month only to save space), departure
airport and time, arrival airport and time, duration.

The list will scroll automatically to display flights on today's date,
or as close as possible.

Simply tap on the one you wish to edit. A 'P' before a flight
signifies that the flight is provisional.

When editing a flight, the 'copy' buttons work slightly differently
to adding a new flight. Rather that copy the values from the last 19/07 EGKK 12:25 LIRP 14:30 (2.1} [
flight entered, they copy from the previous flight in chronological 18/07 LIRP 15115 EGKK 17:25 (2.2)  |¥
order. This means that, for example, if you operate a series of E|‘
flights on the same aircraft having already entered them as

provisional data, you can enter the registration once for the first flight, then use the 'Reg' button to copy
that information into subsequent flights without any further typing.

TMTTOTTTTTW T TOTOTToToToToTToTT]

Note : When you edit a provisional flight, the 'P' box is automatically unchecked as it is assumed that once
a flight has been edited it is confirmed, and no longer provisional data. You can of course re-check the 'P'
box manually. This will happen if you view a flight and tap 'OK' — if you just wish to view a provisional flight
without making any changes, you should tap 'Discard Changes' to avoid saving the flight as non-
provisional.

4.3 Deleting Flights

Tap 'Flight -> Delete'.

You will be presented with a list of stored flights similar to that used to select a flight to edit. Tap on any
flight to delete it. You will first be asked to confirm that you wish to delete the flight, and when you click
'OK" it will be permanently deleted.

Note : Deleting a flight in PilotLog Offline will not remove it from your online log next time you
synchronise. The delete option is provided only for deleting flights added offline. To remove provisional

flights from your online log, you must delete them online. This is a safety feature designed to prevent
accidental deletion of data from your online log during synchronisation.
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4.4 Adding Sims
Tap 'Sim -> Add'.

The first screen contains most sim detail information. Dates must e rr ey i <% 10:36 ()
be entered in dd/mm/yyyy format.

Date: Durakion:

Duration must be entered in the format selected from the Tools | Title ||5im Check | LPCIOPC =

-> Hours Display Format' menu, i.e. hmm, h.m or h.mm. |Sim ”?3? v |F" EE—
Regardless of the format selected, it is acceptable to enter a ~ J

single digit (e.g. '4" instead of '4:00") which will be assumed to be Crew: P[]

a whole number of hours. [T |[Chopper Smith |

"Title' is a short description of the detail. The adjacent drop-down | PIC_|[Buster Level |
box specifies the type of detail. | P2 ||ser |

The 'Sim' box is for the simulator name. This could be the aircraft | Discard Changes | | Clear | | Comrnent. .. |
type, and/or the full approved simulator registration code. The 1231[2[3[4[s5]6[7[8]9]0]-]=
adjacent drop-down box specifies to the type of simulator. Tablq[w[e[r [ty [uli]o]p]I

'Crew' is the crew capacity in which you acted during the detail.  [shift]z [ [c [¥[b][n[m],[.[7]

ctlaii] " [\ ] [4]t]e]=
'Ins' is an abbreviation of 'Instructor'. Enter the crew names in [
the three corresponding boxes.

The 'P' box on the right hand side marks the detail as provisional.

The 'Title', 'Sim', 'Ins, 'PiC' and 'P2' captions are tappable buttons. Tapping these will copy the
corresponding value from the last sim detail added. Note that the Title' and 'Sim' buttons will set the value
of the drop-down selection as well as the text in the box.

Tap 'Comment..." to enter further details:

£ |pilotLog DFfline ¢ 10:44 (D
The 'Comment' caption works in a similar way to the buttons on

the previous screen. It will copy the comment from the last flight :
added, but rather than overwriting the current comment, it will =~ |All 99ing well so far... -
add the text to any already there so that information is not
accidentally lost.

Tap 'Back...' to return to the previous screen.

Tap 'OK' in the top right-hand corner of either screen to save the
sim details. Tapping 'Discard Changes' will lose the current sim

[k
data and return to the previous screen. Discard Changes

123/1[2[3]4[s5[6[7[8]o[0]-[=[«
Tabla[wle|r[t[y[ulifo]p|[]]
CAP[a[s[d[f[a[h[j[k[I]:]"
shiftf z[R [c[v[b[n[m][.[. ]/
ctfain] - [\ ] [4]1]

4]

|
—

[

—

g

4.5 Editing Sims

Tap 'Sim -> Edit'. The process is the same as described in '4.2 Editing Flights', including the notes on
provisional sims being automatically marked as non-provisional and the copy buttons copying from the
previous detail chronologically, rather than the last one added.

4.6 Deleting Sims

Tap 'Sim -> Delete'. The process is the same as described in '4.3 Deleting Flights'. You will be asked to
confirm before any sim detail is deleted. Details deleted offline will not be removed from your online log.
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5.0 Synchronising With Your Online Log

To synchronise, you must upload the 'log.csv' file from your PDA to the PilotLog.co.uk website. Any flights
and/or sim details which you have added or modified offline will be copied into your online log. Aircraft
registrations and airports will be matched against the main online database in the same way as if you had
entered the details directly online. Any errors or warnings will be displayed on screen. If you have modified
both the online and offline versions of a flight or sim detail, you will be asked which one you wish to keep.

First, you must copy your 'log.csv' file from your PDA to your PC. If you keep your 'log.csv' file within the
'My Documents' folder on your PDA (this includes folders within 'My Documents’ such as 'My
Documents\Personal' or 'My Documents\PilotLog Offline") the process is simple and automatic. ActiveSync
will copy the file whenever it is modified, and keep a synchronised copy on your desktop computer.

Open ActiveSync, and check that files are being ?@ 1]
synchronised. There should be a folder icon in the | EEE
'Information Type' list, labelled 'Files' as seen at the
bottom of the list on the right. &

Sync Details Exfre Cptions

If files are not being synchronised, click on the 'Option'
button (circled) or on 'Tools -> Options'. A window Will || cennected
open giving access to ActiveSync options. Synchronized

In the 'Sync Options' tab, look down the list of items
which can be synchronised. Ensure that the box next to || iformation Tvpe Status

'Files' is tiCkEd, then click 'OK'". [l calendar Synchronized
[Elcantacts Synchronized

ActiveSync will now create a folder on your PC within | ElTsss Synchronized
[_Inates Synchronized

the 'My Documents' folder. It will be called 'PDAName B Files Synchronizad
My Documents' (where PDAName is whatever your PDA
happens to be called). This folder will contain a
complete copy of the 'My Documents' folder on your

PDA, including your 'log.csV' file. Options B|

To upload your 'log.csv' file, log in to your online log | 5 Ortiens | Schedue | Fuies |

and click 'Tools -> Synchronise with PilotLog Desktop

Offline'. Browse to the folder 'My To zunchronize a twpe of information, select ite check bos,
DOCUmentS\PDAName My Documents\_,_\log_csv' @ To stop synchronization, clear the chack bax.
where you have stored your 'log.csv' file.
Y Y E Mobile Device | ”~ Settings...
After synchronisation, you must download a new %EZE’E‘Z
'log.csv' file. There is a button at the end of the WI[7] Tasks
synchronisation window to do this, or you can use CICS Favarites
the 'Tools -> New PilotLog Offline log.csv File' menu (1% Packet Access
option. Save this downloaded file back to the same '”'m
folder ('My Documents\PDAName My i.

Documents\...\log.csv') and overwrite the old
'Iog.csv' file. ActiveSync will copy the file back to v Synchronize mobile device clock upon connecting.
your PDA automatically. Server

To enable, dizable or modify spnchronization with a server,
conhect your device.

Next time you run PilotLog Offline, it will load the

[ Enable synchranization with .
new file and display any downloaded provisional nabie synenrenizaton wih & server
flights and sim details. If Pilottog Offline was
running during synchronisation, the file will only be ’T| Carcal |

loaded if you close then re-start the program, or
use 'Tools -> Open Log File' to load the new log file
manually.
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6.0 Troubleshooting

No flights or sim details have been downloaded to my PDA

Only provisional flights and sims are downloaded. If you have no provisional data online, then nothing will
be downloaded. You should still see hours totals information on the PilotLog Offline main screen, and you
can add flights and sim details offline. These will be added to your online log when you synchronise.

All the flights I added offline disappeared when I synchronised my log

See above. If the flights were added as non-provisional data, they are copied to your online log during
synchronisation. As only provisional flights are downloaded in the new 'log.csv' file, you will not see the
flights you added in PilotLog Offline after synchronisation.

This is to save space and processing power on your PDA. If you require a copy of your historic log to carry
with you, consider downloading a backup log file (online, 'Tools -> Download Backup Log File'). See the
online help file for further information.

When I run PilotLog Offline, I get an error ‘log.csv file not found'

First, be sure that you have downloaded a 'log.csv' file and copied it to your PDA. Use File Explorer on your
PDA ('Start -> Programs -> File Explorer') and navigate to the folder where you stored your 'log.csv' file. If
it is missing, you can download a new one from your online log (‘'Tools -> New PilotLog Offline log.csv
File".
If the file is present, then you just need to tell PilotLog Offline where to find it. See section 3.0 of this
guide.

I've added flights offline but I can't find my ‘log.csv' file

If you add flights without first downloading and locating a 'log.csv' file as described in these instructions,
PilotLog Offline will automatically create a 'log.csv' file for you. It will contain any information added offline,
but of course not your hours totals from your online log. The file will be stored in My Documents on your
PDA.

If you downloaded a 'log.csv' file, but have simply forgotten where you stored it on your PDA, tap Tools ->
Open Log File'. Your 'log.csv' file should be shown, along with the folder it is stored in and it's location
(scroll to the right to see this; for example 'Main Memory' or 'SD Card').

My ‘log.csv' file is not being copied to my computer

Only files in My Documents and folders within My Documents are copied. If you move your 'log.csv' file to,
say, a memory card it will not be copied by ActiveSync. You must in this case copy the file manually to your
computer to synchronise, then copy the new 'log.csv' file back to the same location afterwards.

If the 'log.csv' file is in My Documents, check that ActiveSync is set to synchronise files. See section 5.0 of
this guide.

I can't see the copy of 'log.csv' on my computer when I try to synchronise online

You can only access the synchronised copy in 'My Computer\My Documents\PDAName My Documents\...'
when synchronising. You cannot read the 'log.csv' file directly from your PDA via 'My Computer\Mobile
Device\...". Ensure that you are trying to open the file from the correct location.

When I run PilotLog Offline, I see an error ‘Unable to read the registry’

This can be caused by another program accessing the registry while PilotLog Offline needs to. Try closing
and restarting PilotLog Offline. If the error persists, try a soft reset of your PDA. If that fails, uninstall then

reinstall PilotLog Offline. See section 1.0 of this guide. Reinstalling should not cause you to lose any data,
but it would be wise to synchronise with your online log first in any case.
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