
PilotLog Offline for Mac

Version 2.0.2

User Guide

PilotLog Offline is a companion flight editor for the online PilotLog system. Provisional flight and simulator 
detail information is downloaded to your computer, where the details can be updated then re-synchronised 
with your online log. It is also possible to add new flights and simulator details offline if they were not 
previously entered online.

Note : Your entire log is not synchronised with the computer; most data is kept on the online server, and 
only flights and sim details marked as provisional (or newly entered offline) are stored locally.
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1.0 Getting Started

Download and Install the Program
1. Download the PilotLog Offline for Apple Mac program from the PilotLog website. This can be found 

at: http://www.pilotlog.co.uk/downloads.php. You will need to log in to access the PilotLog Offline 
program.

2. Save this file 'PilotLog Offline' to your computer, somewhere that will ensure that it can be found 
easily later (for example, 'Applications' in your user folder).

3. The program is supplied in a ZIP compressed archive; Safari should decompress it automatically, 
resulting in a 'PilotLog Offline' program appearing on your desktop (or wherever your downloaded 
files are saved). If the file is not decompressed automatically (you just see a 'PilotLog.zip' file), you 
will  need  to  extract  the  contents  manually.  Simply  double-click  the  'PilotLog.zip'  file  and  the 
'PilotLog Offline' program should appear alongside it.

4. Copy 'PilotLog Offline' to a suitable location on your computer (click on the icon, and drag it to the 
new location). We would suggest your 'Applications' folder.

5. Optionally, click and drag the icon onto your Dock, for quick access. This will create a shortcut on 
the Dock.
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2.0 Before Running PilotLog Offline for the First Time

IMPORTANT!!!  DO NOT add any flight data until after you have completed the following. Failure to do so 
will result in your flight data being stored in an inaccessible location.

Note : This section can be skipped if you already have a 'log.csv' file on your computer, from a previous 
version of PilotLog Offline.

 1. Download a 'log.csv'  file from PilotLog online.  This  can be done by logging into your PilotLog 
account, and going to 'Tools -> New PilotLog Offline 'log.csv' File'. You will be warned about the 
danger of overwriting existing 'log.csv' files, then allowed to download the data. 

 2. Save the 'log.csv' file to your computer. The 'log.csv' file can be saved anywhere you choose; we 
would generally recommend somwhere within 'Documents'. Remember where you saved it for the 
next step...

3.0 Running PilotLog Offline for the First Time

 1. To run PilotLog Offline, double-click the 'PilotLog Offline' program icon, or single-click the shortcut 
on the Dock (if you created one).

 2. You will see a message 'No Flights To Display' the first time you run the program.
 3. To load the 'log.csv' file, click 'File -> Open Log File'. DO NOT ADD FLIGHTS BEFORE PERFORMING 

THIS STEP.
 4. Navigate to the folder where you saved your 'log.csv' file, and click 'Open'. The file will be loaded, 

and your hours totals displayed in the main program window.
 5. Set the hours display format ('Tools -> Hours Display') to suit your personal preference.  As in the 

online log, this affects all hours totals, and the entry of simulator detail durations. Flight times are 
always entered as hh:mm.
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4.0 Using PilotLog Offline

Depending on your circumstances, there are several ways to use PilotLog Offline:

If your company produces planned rosters in a form that can be downloaded to PilotLog, import your 
planned roster online*. Synchronise with PilotLog Offline and all the planned flights will be copied to your 
computer. Enter actual flight times and other information as you complete each flight, then synchronise 
with your online log at a convenient time.

If you have a planned roster but no download facility, you can enter your planned roster manually online or 
offline as provisional flights. Then simply synchronise as above. Only flights marked as provisional will be 
downloaded, so you must check the 'provisional' option when entering planned flights online. These flights 
will be highlighted in grey in your online log, and marked with a 'P' in PilotLog Offline.

If you have no planned roster, or operate unplanned flights (e.g. from standby), you can add the flight(s) 
using PilotLog Offline. The new flights will be inserted into your online log book when you synchronise.

On the left is a list of stored flights. The information displayed is date, departure airport and time, arrival 
airport and time, duration. A 'P' before a flight signifies that the flight is provisional.

Buttons above the list allow switching between Flight Mode and Sim Mode. The list contents will change to 
display flights or sim details, as appropriate.

Buttons below the list allow you to delete or edit the selected flight or sim detail, or add a new flight or sim 
detail, depending on the current mode selected.

On the right is summary information:

The number of flights and sims stored on your computer, and the number of these which are provisional, 
as opposed to confirmed data.
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Your total flying hours in the past 28 days up to today. The figure in brackets includes provisional (planned) 
flights, if there are any in the period.

Projected flying hours for the 28 days up to tomorrow, again with a provisional figure in brackets if there 
are any planned flights affecting this period.

Total hours in your log book.

The File menu contains an option to open a 'log.csv' file, and to exit the program.

The Tools menu allows you to select your preferred hours display format. This affects totals displayed on 
the main screen, and flight and sim duration displays. Flight departure and arrival times will always be 
displayed as hh:mm.

The Help menu contains a link to the About screen, showing software version information which you should 
quote in any support queries.

* Note : Not all roster formats have been submitted to PilotLog for configuration. If you would like to use 
this feature but find that it is not available, please e-mail us at development@pilotlog.co.uk, attaching 
sample rosters.
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4.1 Adding Flights

Check that you are in Flight Mode (click the 'Flight Mode' button), then click 'Add'.

Dates must be entered in dd/mm/yyyy format. Times can be entered as hh:mm, h:mm, hhmm or hmm. 
Note that the colon (:) can be omitted for ease of typing.

Airports should be entered as ICAO codes, although IATA codes will also be recognised, as will full or part 
names. Note that airport names (and aircraft registrations) will not be checked until you synchronise your 
flights online. Errors may be difficult to spot, so it is better to stick to ICAO or IATA codes.

'%' is the percentage of the flight which is claimed for experience purposes (e.g. if you were one of several 
co-pilots).

'Crew' is the crew capacity under which you operated the flight.

The check-box options correspond to the options in the PilotLog program:

A – Autoland
L – Landing Pilot (checked depending on crew capacity)
I – Instrument Flight (checked by default)
X – Exclude Hours (from 28-day totals etc)
P – Provisional Data

Click 'Save' in the bottom right-hand corner of the window to save the flight details. Clicking 'Discard' will 
lose the current flight data and return to the previous view.

Pressing the 'Enter'  key while adding a flight will  save the details  in the same way as clicking 'Save'. 
Similarly, pressing the 'Escape' key ('Esc') has the same effect as clicking 'Discard'.
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4.2 Editing Flights

There are several ways to edit a flight:

 1. Click a flight in the list, then click the 'Edit' button.
 2. Double-click a flight in the list.
 3. Select a flight in the list with the up/down cursor keys, and press 'Enter' on the keyboard.

The editing display is exactly the same as for adding a new flight. 

The 'Reg', 'PiC', 'P2', 'From' and 'To' captions are buttons. Clicking these will copy the corresponding value 
from the last flight in chronological order.

This means that, for example, if you operate a series of flights on the same aircraft having already entered 
them as provisional data, you can enter the registration once for the first flight, then use the 'copy' button 
to copy that information into subsequent flights without any further typing.

The button above the 'Comment' box works in a similar way to other buttons. It will copy the comment 
from the last flight, but rather than overwriting the current comment, it will add the text to any already 
there so that information is not accidentally lost.

Note : When you edit a provisional flight, the 'P' box is automatically unchecked as it is assumed that once 
a flight has been edited it is confirmed, and no longer provisional data. You can of course re-check the 'P' 
box manually. This will happen if you view a flight then save it – if you just wish to view a provisional flight 
without making any changes, you should click 'Discard' or press 'Escape' to avoid saving the flight as non-
provisional.
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4.3 Deleting Flights

Select a flight from the list, and click 'Delete'.

You will first be asked to confirm that you wish to delete the flight, and when you click 'OK' it will be 
permanently deleted.

Note  : Deleting  a  flight  in  PilotLog  Offline  will  not  remove  it  from  your  online  log  next  time  you 
synchronise. The delete option is provided only for deleting flights added offline. To remove provisional 
flights from your online log, you must delete then online. This is a safety feature designed to prevent 
accidental deletion of data from your online log during synchronisation.
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4.4 Adding Sims

Check that you are in Sim Mode (click the 'Sim Mode' button), then click 'Add'.

The list of sim details on the left shows date, duration, title and sim name for each detail.

Dates must be entered in dd/mm/yyyy format.

Duration ('Dur') must be entered in the format selected from the 'Tools -> Hours Display Format' menu, i.e. 
h:mm, h.m or h.mm. Regardless of the format selected, it is acceptable to enter a single digit (e.g. '4' 
instead of '4:00') which will be assumed to be a whole number of hours.

'Title' is a short description of the detail. A drop-down box allows you to specify the type of detail.

The 'Sim' box is for the simulator name. This could be the aircraft type, and/or the full approved simulator 
registration code. A drop-down box allows you to specify the type of simulator.

'Ins' is an abbreviation of 'Instructor'. Enter the crew names in the three corresponding boxes.

'Crew' is the crew capacity in which you acted during the detail.

The 'P' box on the right hand side marks the detail as provisional.

The 'copy' buttons work as for adding a flight, in that the ones next to the crew names boxes will copy the 
crew names from the last sim added, while the one above the comment box will add the previous comment 
to any text already in the box. The 'Title' and 'Sim' buttons will copy both the text and drop-down option 
from the last sim detail (e.g. in the figure above, 'Sim Check' and 'LPC/OPC' would both be copied by 
tapping 'Title').

Click 'Save' in the bottom right-hand corner of the screen, or press 'Enter' on the keyboard, to save the sim 
detail. Clicking 'Discard' or pressing 'Escape' will lose the current sim data and return to the previous view.
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4.5 Editing Sims

Select a sim detail and click 'Edit' or press 'Enter'. The process is the same as described in '4.2 Editing 
Flights', including the notes on provisional sims being automatically marked as non-provisional.

The 'Title' and 'Sim' buttons will copy both the text and drop-down option from the last sim detail.

4.6 Deleting Sims

Select a sim detail from the list, and click 'Delete'.

The process is the same as described in '4.3 Deleting Flights'. You will be asked to confirm before any sim 
detail is deleted. Details deleted offline will not be removed from your online log.
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5.0 Synchronising With Your Online Log

To synchronise, you must upload the 'log.csv' file from your computer to the PilotLog.co.uk website. Any 
flights and/or sim details which you have added or modified offline will be copied into your online log. 
Aircraft registrations and airports will be matched against the main online database in the same way as if 
you had entered the details directly online. Any errors or warnings will be displayed on screen. If you have 
modified both the online and offline versions of a flight or sim detail, you will be asked which one you wish 
to keep.

To upload your 'log.csv' file, log in to your online log and click 'Tools -> Synchronise with PilotLog Offline'. 
Browse to the folder on your computer where you have stored your 'log.csv' file.

After  synchronisation,  you  must  download  a  new 'log.csv'  file.  There  is  a  button  at  the  end  of  the 
synchronisation window to do this, or you can use the 'Tools -> New PilotLog Offline log.csv File' menu 
option. Save this downloaded file to your computer. You should save it in the same location as the old 
'log.csv' file, overwriting the old version with the new one.

Next time you run PilotLog Offline, it will load the new file and display any downloaded provisional flights 
and sim details. If PilotLog Offline was running during synchronisation, the file will only be loaded if you 
close then re-start the program, or use 'File -> Open Log File' to load the new log file manually.
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6.0 Troubleshooting

No flights or sim details have been downloaded to my computer

Only provisional flights and sims are downloaded. If you have no provisional data online, then nothing will 
be downloaded. You should still see hours totals information on the PilotLog Offline main screen, and you 
can add flights and sim details offline. These will be added to your online log when you synchronise.

All the flights I added offline disappeared when I synchronised my log

See above. If the flights were added as non-provisional data, they are copied to your online log during 
synchronisation. As only provisional flights are downloaded in the new 'log.csv' file, you will not see the 
flights you added in PilotLog Offline after synchronisation.
If you require a copy of your historic log to carry with you, consider downloading a backup log file (online, 
'Tools -> Download Backup Log File'). See the online help file for further information.

When I run PilotLog Offline, I get an error 'No Flights to Display'

First, be sure that you have downloaded a 'log.csv' file and saved it to your computer. If it is missing, you 
can download a new one from your online log ('Tools -> New PilotLog Offline log.csv File').
If the file is present, then you just need to tell PilotLog Offline where to find it. See  section 3.0 of this 
guide.

I've added flights offline but I can't find my 'log.csv' file

If  you add flights  offline  without  first  downloading  and  opening  a  'log.csv'  file  as  described in  these 
instructions, PilotLog Offline will automatically create a 'log.csv' file for you. It will contain any information 
added offline, but of course not your hours totals from your online log. The file will be stored within the 
PilotLog Offline program package. If you are unable to access the 'log.csv' file, contact PilotLog support by 
e-mail, attaching a copy of your 'PilotLog Offline' program (click on the 'PilotLog Offline' icon on your hard 
disk, and from the 'File' menu select 'Create Archive of “PilotLog Offline”. This will create a .zip archive 
which can be sent by e-mail).
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